In this post, we will dive deep into CVE-2017-3167, a vulnerability detected in the Apache HTTP Server Project. This vulnerability affects versions 2.2.x before 2.2.33 and 2.4.x before 2.4.26, with the potential to lead to authentication requirements being bypassed if specific third-party modules use the ap_get_basic_auth_pw() function outside of the authentication phase.

We will analyze this issue to understand how it works, what its implications are, and study the code snippets to see how the exploit functions. Further, we will provide links to the original references and patch notes to help users safeguard their Apache HTTP Servers from potential attackers.

Vulnerability Overview

The vulnerability (CVE-2017-3167) lies in the misuse of the ap_get_basic_auth_pw() function. This function is primarily intended to be employed during the authentication phase, allowing modules to retrieve a user's password for comparison with what they provided when prompted. However, when utilized outside the authentication phase by third-party modules, this can lead to authentication requirements being bypassed altogether.

Exploit Details

According to the Common Vulnerabilities and Exposures (CVE) database, attackers can exploit this vulnerability to bypass authentication requirements and gain unauthorized access to restricted resources.

For example, suppose a third-party module makes use of ap_get_basic_auth_pw() outside of the authentication phase. In that case, it could cause the server to cache these authentication credentials, which may, in turn, be inadvertently applied to another request in the same connection. Consequently, attackers could potentially exploit this to bypass the authentication requirements set by the server administrator.

Below is an example of how the vulnerable code could be implemented within the http_request.c file

/* Vulnerable code example */

AP_DECLARE(int) ap_get_basic_auth_pw(request_rec *r, const char **pw)
    const char *auth_line;
    char *user;
    apr_status_t status;

    /* Get the Authorization header */
    auth_line = apr_table_get(r->headers_in, "Authorization");

    /* Validate the Authorization header format */
    if (!(auth_line && auth_type(r))) {
        return DECLINED;

    /* Retrieve user credentials */
    status = apr_password_validate(auth_line, "Basic", &user, pw);

    if (status != APR_SUCCESS) {

    r->user = apr_pstrdup(r->pool, user);

    return OK;

Patch and Fixes

The Apache HTTP Server Project's security team promptly addressed the vulnerability with the release of version 2.4.26 on June 19, 2017. To resolve this issue, it is highly recommended that users upgrade their servers to this patched version or later. Additionally, if running Apache 2.2.x, users are advised to upgrade to 2.2.33, which also includes the necessary fix.

Here are some essential references to more in-depth information about the vulnerability

1. CVE Record: NVD - CVE-2017-3167
2. Apache httpd 2.4.26 Announcement: Apache httpd 2.4.26 Released
3. Apache httpd 2.2.33 Announcement: Apache httpd 2.2.33 Released
4. Apache httpd Security Advisory: Advisory for CVE-2017-3167


CVE-2017-3167 is a noteworthy vulnerability affecting Apache HTTP Server, specifically in versions 2.2.x before 2.2.33 and 2.4.x before 2.4.26. The improper use of the ap_get_basic_auth_pw() function by third-party modules can lead to authentication requirements being bypassed, potentially enabling unauthorized access to server resources. Users are urged to upgrade their Apache servers to the patched versions mentioned above to protect against any potential exploitation.


Published on: 06/20/2017 01:29:00 UTC
Last modified on: 06/06/2021 11:15:00 UTC