Adobe Acrobat Reader DC is a widely used program for viewing and editing PDF documents. However, recent attention has been drawn to a critical vulnerability found in version 21.007.20099 (and earlier), 20.004.30017 (and earlier), and 17.011.30204 (and earlier). Adobe has issued a security patch via the February 2023 Patch Tuesday update to address the out-of-bounds write vulnerability that could lead to arbitrary code execution on users' machines. The CVE-ID assigned to this vulnerability is CVE-2022-24092.

The vulnerability results from a flaw in the way Acrobat Reader DC handles malicious fonts embedded in PDF documents. Attackers can exploit this vulnerability to execute arbitrary code in the context of the current user by tricking the victim into opening the malicious PDF containing corrupt font files. Successful exploitation of this vulnerability requires user interaction, hence Adobe has urged users to update Acrobat Reader DC to the latest version as soon as possible.


The root cause of the vulnerability (CVE-2022-24092) is an out-of-bounds write error in the CoolType library, which is used by Acrobat Reader DC for rendering fonts. The critical vulnerability can be triggered when parsing a crafted font file embedded within a PDF document. Upon opening the malicious file, the error could cause a carefully crafted memory corruption, leading to arbitrary code execution on the affected machine.

A simplified code snippet that demonstrates the cause of vulnerability is as follows

void parse_font_file(uint8_t *font_file, uint32_t size) {
  uint32_t index;
  uint32_t write_offset;

  // Read the index from the font_file
  index = read_index(font_file, size);

  // Calculate the write offset based on the index
  write_offset = calculate_write_offset(index);

  // Out-of-bounds write due to a faulty index
  font_data[write_offset] = font_file[index];

If the index value is larger than the actual size of the font_file, an out-of-bounds write would occur, leading to memory corruption and potential arbitrary code execution.

Original References

1. Adobe Security Bulletin: APSB23-02
2. CVE Mitre Database Entry: CVE-2022-24092

Exploit Details

To exploit CVE-2022-24092, an attacker would need to create a malicious PDF document containing a crafted font file that triggers the out-of-bounds write vulnerability. The attacker would then need to convince the victim to open this crafted PDF in Acrobat Reader DC. This could be done through social engineering tactics, such as embedding the malicious file in a phishing email or hosting it on a seemingly legitimate website.

Once the victim opens the malicious PDF, Acrobat Reader DC would parse the corrupt font file, writing data to invalid memory locations and causing a carefully crafted, controlled memory corruption. This would pave the way for arbitrary code execution in the context of the current user on the victim's machine. A successful exploit could allow the attacker to view, modify, or delete sensitive data, install malware or ransomware, or execute any action within the context of the compromised user.


To mitigate this vulnerability, it is highly recommended to update Acrobat Reader DC to the following patched versions:

Follow the on-screen instructions to complete the update process.

Users should be mindful of the PDF files they open, and organizations must enforce security awareness training among their employees to reduce the risk of social engineering attacks that could leverage this vulnerability for malicious purposes.


Published on: 03/18/2022 18:15:00 UTC
Last modified on: 03/25/2022 19:40:00 UTC