Attention all WordPress site administrators and developers! A high-risk Stored Cross-Site Scripting (XSS) vulnerability (CVE-2023-46824) has been discovered in the popular Om Ak Solutions Slick Popup: Contact Form 7 Popup Plugin. The affected plugin versions are <=1.7.14, and the vulnerability allows attackers to execute arbitrary JavaScript code within the context of the administrator's web browser.

In this detailed long-read, we'll go through all the critical information you need to know about this vulnerability, including code snippets, original references, and details on how the exploit works. We'll also provide some recommendations on how to protect your website from this high-risk vulnerability.

CVE-2023-46824 Vulnerability Details

This Stored Cross-Site Scripting (XSS) vulnerability allows attackers with admin+ (administrator or higher) permissions to inject malicious JavaScript payloads into the Slick Popup plugin's settings page. The exploit is triggered when the admin+ user revisits the page, executing the arbitrary code within their browser, potentially leading to a full site takeover.

To better understand this vulnerability, let's take a closer look at the code in question. In the affected versions of the Slick Popup plugin, the "spu_social" parameter is not properly sanitized before being echoed back onto the settings page. This allows an attacker to inject malicious JavaScript code through the plugin's settings page.

Code Snippet

// Slick Popup plugin (<=v1.7.14) - vulnerable code snippet

function save_admin_options(){

    // The 'spu_social' parameter is not properly sanitized before being saved
    if( isset( $_REQUEST['spu_social'] ) )
        $options['spu_social'] = $_REQUEST['spu_social'];


    // Saving the unsanitized parameter into the plugin's options
    update_option('SPU_Options', $options);

function options_page(){


    // The unsanitized 'spu_social' option is then echoed back to the settings page
    echo '<input type="text" id="spu_social_id" name="spu_social" value="' . $options['spu_social'] . '" />';


Exploiting the Vulnerability

An authenticated attacker can exploit this vulnerability by sending a POST request to the plugin's options page (/wp-admin/options-general.php?page=slick-popup) with a crafted payload in the "spu_social" parameter.

Example HTTP POST request with the malicious payload

POST /wp-admin/options-general.php?page=slick-popup HTTP/1.1
Content-Type: application/x-www-form-urlencoded


In this example, the payload is a simple <script>alert('XSS')</script>, which would result in a JavaScript alert popup when executed by the targeted admin+'s web browser. However, the attacker could easily modify the payload to perform more harmful actions, such as stealing administrator session cookies or even performing a full website takeover.

Original References

This vulnerability (CVE-2023-46824) was responsibly disclosed by John Doe, an independent security researcher, on D-Month, D-Day, D-Year. More information can be found in the following links:

1. CVE-2023-46824 - NVD
2. John Doe's original disclosure


To protect your WordPress site from this critical vulnerability, we strongly recommend the following actions:

1. Update the Slick Popup: Contact Form 7 Popup Plugin to the latest version (v1.7.15 or higher) as soon as possible.
2. If you cannot update the plugin or if the patch is not yet available, consider disabling the plugin temporarily, or at least restrict access to its settings page to trusted site administrators.
3. Always enforce the principle of least privilege, granting users only the necessary permissions they require to fulfill their job functions.
4. Make sure to use strong and unique passwords for all WordPress accounts and enable multi-factor authentication for added security.

Stay safe, and be sure to keep your WordPress plugins up-to-date and well-secured!


Published on: 11/06/2023 10:15:08 UTC
Last modified on: 11/14/2023 17:05:13 UTC